Setting NAT pada CISCO Router

Network Adress Translation (NAT) Merupakan sebuah teknologi jaringan yang menerjemahkan IP Lokal pada jaringan menjadi IP Publik pada Router, sehingga semua ip lokal bisa menggunakan satu IP Publik saja. Pada Cisco Router kita kenal ada banyak protokol routing OSPF, RIP, BGP dll, termasuk juga static routing (ip route). Pada setting static routing di cisco kita diharuskan mengisi route pada kedua sisi router, tapi dengan NAT cukup di satu router saja. Kali ini saya akan coba share tentang Setting NAT pada CISCO Router

Asumsi :

  • Jaringan Lokal : 172.16.37.0/24 (FastEthernet 0/1) –> Inside Interface
  • WAN / Public IP: 222.124.158.56 (FastEthernet 0/0) –> Outside Interface

NAT pada cisco bisa dibuat dengan menggunakan Access List dan Penentuan inside / outside interface. Berikut perintah nya pada cisco:

Setting IP WAN dan Outside Interface

router> en
router# conf t
router(config)# interface FastEthernet 0/0
router(config-if)# ip address 222.124.158.56 255.255.255.0
router(config-if)# no sh
router(config-if)# ip nat outside
router(config-if)# exit

Setting IP LAN dan Inside Interface

router(config)# interface FastEthernet 0/1
router(config-if)# ip address 172.16.37.1 255.255.255.0
router(config-if)# no sh
router(config-if)# ip nat inside
router(config-if)# exit

Membuat Access List dan Assign NAT

router(config)# access-list 20 permit 172.16.37.0 0.0.0.255
router(config)# ip nat inside source list 20 interface FastEthernet 0/0 overload

Dengan perintah diatas semua paket data yang dikirim dari source 172.16.37.0/24 akan diterjemahkan dengan ip yang ada pada outside interface, yaitu FastEthernet 0/0. Terakhir tinggal dicoba ping dari client LAN, seharusnya sudah bisa terkoneksi/ping ke jaringan WAN/Publik nya 😉 Selamat mencoba 😀

2 thoughts on “Setting NAT pada CISCO Router

  1. Fadhly Ridha Post author

    kalau mau setting nat untuk client dibelakang routernya, router harus bisa ping dulu ke network wan nya. coba di cek default-gatewaynya apakah sudah ada atau belum.

Tinggalkan Komentar

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: